游戏技术文章

Easyui1.3.4+IIS6.0+IE8兼容问题解决

时间:2017-1-1 20:13:31  作者:棋牌资源网  来源:棋牌资源网  查看:7736  评论:0
内容摘要:刚刚学习JQuery Easyui,就遇到了拦路虎,最新版本1.3.4下载下来部署到win2003 + IIS6.0中发现所有demo都不可以渲染,IE8提示错误如下:详细内容如下:用户代理: Mozilla/4.0 (compatible; MSIE 8.0; Windows ...
刚刚学习JQuery Easyui,就遇到了拦路虎,最新版本1.3.4下载下来部署到win2003 + IIS6.0中发现所有demo都不可以渲染,IE8提示错误如下:

Easyui1.3.4+IIS6.0+IE8兼容问题解决

详细内容如下:

用户代理: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.2; Trident/4.0; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; InfoPath.2; MS-RTC LM 8; .NET4.0C; .NET4.0E)
时间戳: Fri, 22 Nov 2013 05:46:30 UTC


消息: 对象不支持此属性或方法
行: 4
字符: 6102
代码: 0
URI: http://localhost/Easyui/jquery.min.js


消息: 'jQuery' 未定义
行: 12
字符: 1
代码: 0
URI: http://localhost/Easyui/jquery.easyui.min.js


消息: 缺少对象
行: 19
字符: 1
代码: 0
URI: http://localhost/Easyui/demo/dialog/toolbarbuttons.html
 

上网搜了下,发现说明白解决方案的不多,于是记录了一下:

根本原因是JQuery的版本造成IE8及以下兼容的问题,首先是测试Firefox、Chrome不存在任何问题,初步判断是IE兼容的问题,根据提示的错误应该跟jquery有关,查找下载easyui早期版本,发现不存在问题,判定就是jquery的问题,于是替换easyui文件夹下的jquery.min.js文件,因为早期版本都是带版本号的文件名称,替换文件需要跟源文件保持一致,jquery-1.7.2.min.js 替换 jquery.min.js,重新运行IIS发现问题解决如图

Easyui1.3.4+IIS6.0+IE8兼容问题解决

 

可以到jquery官方下载1.10.2最新版本,替换后发现完美兼容

标签:Easyui1.3.4+IIS6.0+IE8兼容问题解决 

欢迎加入VIP,【VIP售价:只要288元永久VIP会员】畅享商业棋牌游戏程序下载,点击开通!

下载说明


☉本站所有源码和资源均由站长亲自测试-绝对保证都可以架设,运营!
☉如源码和资源有损坏或所有链接均不能下载,请告知管理员,

☉本站软件和源码大部分为站长独资,资源购买和收集,放心下载!

☉唯一站长QQ:1004003180  [人格担保-本站注重诚信!]

☉购买建议E-mail:1004003180@qq.com   源码收购 E-mail:1004003180@qq.com    

☉本站文件解压密码  【文章内都自带解压密码,每个密码不同!】


本站提供的所有源码,均来源站长提供,仅学习交流 浙ICP备09009969号

由此产生不良后果和法律责任与本站无关,如果侵犯了您的版权,请来信告知 1004003180@qq.com 将及时更正和删除! 

Copyright © 2008-2022 棋牌资源网,你身边的棋牌资源下载站    All Rights Reserved